Back to overview
Resolved

Precision Routing Services (PRS) - Possible Minor Latency / Service Degradation

Mar 12, 2026 at 7:34pm UTC
Affected services
Precision Routing Service - PRS

Resolved
Mar 14, 2026 at 7:41pm UTC

🌍 Global Rollout: Singapore Routing Now Live

What's going on?

Following the successful update and testing of our regional gateway tools in the Philippines, we are now rolling out these backend optimizations to our entire global infrastructure. This update officially enables International Routing capabilities for all users across the Precision Routing Services (PRS) network.


What this means for you:

  • No Action Required The rollout is automated. All existing configurations will remain active, and no manual changes are needed to your account.
  • Enhanced Capability All enterprise users now have access to optimized singapore international routing protocols, moving beyond regional limitations.
  • System Stability The rollout is being monitored in real-time. While we transition the entire update, our core routing engine remains 100% stable.

Created
Mar 12, 2026 at 7:34pm UTC

🛠️ Service Notice: Internal Tooling Update

What's going on?

We are currently updating our internal SMS Philippines gateway tools. This is a backend optimization specifically designed to support our newly expanded international routing capabilities.


What this means for you:

  • No Action Required PRS remains fully operational. You do not need to change any settings or configurations on your end.
  • Potential Performance Impact Users may experience brief periods of service degradation or slight latency increases specifically for SMS routing within the Philippines region while the update is finalized.
  • Core Stability Our core routing engine remains stable and untouched; this update is isolated to regional gateway tools.